Phone Support Unavailable
Incident Report for Wink
Resolved
Phone support is now fully operational.
Posted 4 months ago. Apr 01, 2017 - 18:41 UTC
Investigating
We are investigating an issue with inbound and outbound phone support.
Posted 4 months ago. Apr 01, 2017 - 18:29 UTC