Password Reset and Account Confirmation Issues
Incident Report for Wink
Resolved
This incident has been resolved.
Posted 7 months ago. May 05, 2018 - 02:50 UTC
Investigating
We are investigating an issue that is preventing users from accessing Password Reset and Account Confirmation links.
Posted 7 months ago. May 05, 2018 - 02:14 UTC