Wink technical support phone outage
Incident Report for Wink
Resolved
Technical difficulties have been resolved. "Our phone lines are back up and running!
Posted 10 months ago. Jun 18, 2018 - 23:57 UTC
Investigating
We're currently experiencing technical difficulties with our phone system. We are working to get everything back up and running. We apologize for any inconvenience!
Posted 10 months ago. Jun 18, 2018 - 23:21 UTC
This incident affected: Wink Phone Support.