Email not being sent
Incident Report for Wink
Resolved
This issue has been resolved.
Posted 10 months ago. Feb 22, 2018 - 17:26 UTC
Investigating
We are investigating an issue with emails not being sent.
Posted 10 months ago. Feb 22, 2018 - 16:26 UTC