Phone/Email Customer Support Currently Down.
Incident Report for Wink
Resolved
This incident has been resolved.
Posted 14 days ago. Nov 05, 2018 - 15:32 UTC
Identified
Customer Support is currently experiencing technical difficulties due to power outage. This is affecting phone and email customer support.
Posted 16 days ago. Nov 03, 2018 - 21:35 UTC
This incident affected: Wink Phone Support.