Customer Service - Power Outage
Incident Report for Wink
Resolved
Power has been restored to the customer service office.
Posted 14 days ago. Jun 05, 2019 - 16:49 UTC
Monitoring
A power outage is affecting the area of our customer service center. Local officials and utilities are working to restore services to the area. We apologize for any inconveniences. DM @WinkSupport or email Questions@Wink.com for assistance. Thank you.
Posted 14 days ago. Jun 05, 2019 - 15:17 UTC
This incident affected: Wink Phone Support.