Customer Support Outage
Incident Report for Wink
Resolved
This incident has been resolved.
Posted Sep 25, 2019 - 18:19 UTC
Investigating
Wink customer support is currently experiencing technical difficulties with their call routing system. For email support please email questions@wink.com and we will provide assistance as soon as possible.
Posted Sep 24, 2019 - 15:03 UTC
This incident affected: Wink Phone Support.