CS Services Currently Down
Incident Report for Wink
Resolved
Customer Support services (phone & email) have been restored. Thank you for your patience.
Posted Sep 17, 2019 - 19:58 UTC
Identified
The customer service office is experiencing technical difficulties with our CS system. Phone lines and emails are currently down. We apologize for any inconveniences.
Posted Sep 17, 2019 - 19:29 UTC
This incident affected: Wink Phone Support.